Loading
 
Support Support Home » APIs » XIMEA Linux Software Package » Linux Firewire Support

Linux Firewire Support

XIMEA Linux Software Package includes support for Firewire cameras.

Prerequisites

Adapter

The implementation is tested only on Selected Firewire Adapters

Firewire Stack

The Linux, where Software Package is installed must have special Firewire software stack.

Ubuntu 10.04

  • disable default firewire and enable raw1394 by modifying /etc/modprobe.d/blacklist-firewire.conf to something like:
    # blacklist firewire-ohci
    # blacklist firewire-sbp2
    # blacklist firewire-net
    blacklist ohci1394
    blacklist sbp2
    blacklist eth1394
    blacklist dv1394
    blacklist raw1394
    blacklist video1394
    
  • update initramfs
    sudo update-initramfs -u
    sudo reboot
    

Ubuntu newer versions

Newer versions of Ubuntu use newer Firewire stack called Juju (CONFIG_FIREWIRE option in kernel is required)
See Kernel.Org for more.
Also rebuilding initramfs after changes to modprobe.d/ will be needed.

Installation